etiquetags 1.1

sisi escribió esto a las 18:27

Ya podéis visitar la nueva web de etiquetags así como echar un vistazo a la demo de la nueva versión 2.0 y descargar el nuevo plugin para WordPress etiquetags20

logo etiquetags
Ya está disponible para su descarga una nueva versión de etiquetags : etiquetags1.1, que incorpora los siguientes cambios:

  1. Corrección del fallo de inserción de imágenes en IExplorer y Opera.
  2. Una nueva función de previo en la misma ventana. El botón “vista previa” conmuta entre el modo de edición y el de previsualización.

Y ya, aprovechando, se han modificado los paquetes para WordPress y Dotclear, facilitando así la instalación de etiquetags:

  1. Ya no hace falta renombrar el archivo etiquetags.js como quicktags.js o toolbar.js.
  2. Ya no hace falta editar las rutas para los iconos y formularios, a no ser que el blog no esté instalado el directorio root de vuestro servidor.

Para echar un vistazo:

Comparte este artículo:
  • Meneame
  • del.icio.us
  • Digg
  • Facebook
  • TwitThis
  • Google
  • Live
  • E-mail this story to a friend!
  • Print this article!

21 comentarios en “etiquetags 1.1”


  1. Cruzul dice:

    Un paso máis, Etiquetags 1.1

    Un paso máis dunha ferramenta xa imprescindíbel para editar o contido do noso blog supono sen lugar a dúbidas o integrar o previo no mesmo espazo da textarea.


  2. Alfonso dice:

    ¡Qué máquinas!!!! ;)


  3. sisifodichoso dice:

    Maquinitas felices si todo esto le resulta útil a alguien :-)


  4. Ana* dice:

    A mí, por ejemplo :D


  5. zetxek dice:

    Hola…

    No me acaba de funcionar bien el editor: me carga bien el editor principal, pero al hacer click para usar alguna de las funciones que sacan un pop-up (insertar enlace o insertar imagen), me salta un pequeño pop-up, pero con un error 404 de que no encuentra la página.
    Subí el archivo quicktag.js y los dos directorios de iconos y formularios (de hecho, accediendo a http://www.bloqnum.com/wp-includes/js/forms/ se pueden ver), así que no soy capaz de localizar el problema. Mi blog está en el directorio principal, así que no tendría que editar el directorio…

    Alguna pista?


  6. sisifodichoso dice:

    Hola zetxek :-)
    Uf pues lo he estado mirando y no lo sé …
    si no fuera porque he estado viendo tus archivos te diría que podría ser un asunto de permisos, revísalos lo primero (los de los formularios formlink y formimg), si es que no lo has hecho ya.
    Por otro lado, si ves los iconos, eso significa que las rutas relativas son correctas ¿no? prueba a editar tu quicktags y poner para los forms la ruta absoluta, a ver si así te funciona. Recuerda que para cada cambio que hagas tienes que recargar la página de edición de wordpress para que estos cambios sean efectivos … y cuéntanos qué tal …


  7. Drupal 5.0 dice:

    hola, estoy usando etiquetags para algunos sitios en drupal y me parece un excelente editor de texto, me pregunto si tienen pensado actualizar la version de etiquetags para que sea compatible con drupal 5.0, pueto que la version actual no corre en la ultima version de drupal. Saludos.


  8. sisifodichoso dice:

    Hola :-)
    No sabía que no era compatible con la versión 5, lo miraremos seguro aunque no sé si lo conseguiremos ;-)
    Muchas gracias por el aviso
    Saludos


  9. sisifodichoso dice:

    Sólo quería decirte, drupal5.0, que acabo de hacer que funcione (yupi) . Sólo falta pulirlo un poco. En cuanto lo tenga aviso … :-)

    saludos


  10. Edu dice:

    Saludos a todos y felicitaciones por el programa, es realmente util. Estoy intentando utilizarlo, pero tengo un problemilla rellacionado con el posicionamiento de los botones y es que todas las imagenes separadoras que se insertan entre los botones me las coloca en una nueva linea. Es decir, me pone grupos de botones en la misma linea pero cuando llega a un separador lo mete en una linea nueva y me queda algo asi:
    boton1 boton2 boton3
    separador
    boton4 ……
    separador…..

    y asi con todos los separadores. No se a que puede deberse, me podria alguien echar una mano?????????????
    gracias


  11. sisifodichoso dice:

    Hola Edu,
    Ante todo, gracias por usar etiquetags.
    Qué “curioso” eso que te pasa ¿no? Así, sin más, no sé decirte a qué puede deberse.
    Dinos qué versión de etiquetags estás utilizando. ¿Es un WP? ¿o en otro CMS? más que nada por mirar el código …

    un saludo :-)


  12. Edu dice:

    gracias x contestar!!!!
    el codigo es una copia del demo
    edToolbar();

    varedNotice=document.getElementById(‘notice’);

    Estoy utilizando etiquetags v1.1 y estoy intentando meterlo en una pagina web php. Lo curioso es que todos los botones funcionan correctamente sobre el textarea, pero tengo el problema del posicionamiento. LA cosa es que yo tengo aparte otras hojas de estilo, pero me he asegurado de que no haya ninguna incompatibilidad. Pero no tengo ni idea de que puede ser.

    :gracias:


  13. Edu dice:

    El codigo no se ha copiado bien, ahi va:
    edToolbar();

    var edNotice=document.getElementById(‘notice’);


  14. sisifodichoso dice:

    Yo diría que el código correcto debería ser este:

    <script type="text/javascript">edToolbar();</script>
    <textarea id="notice" rows="20" cols="50">
    </textarea><script type="text/javascript">var edCanvas = document.getElementById('notice');</script>


  15. Edu dice:

    ya está! ya solucione el problema de posicionamiento. La verdad es que no se cual sería el problema concreto pero yo lo he solucionado así.
    Al observar que con los botones no me daba ese problema pues decidí ‘engañar’ al navegador indicandole que las imágenes separadoras eran tambien botones. Asi en la parte del codigo donde insertaba las imagenes las etiquetas ” y ‘ …… ‘
    Al mismo tiempo, para que funcionara creé tambien en style.css la siguiente regla:

    #ed_button_separator{
    width: 10px;
    height: 25px;
    border: 0px;
    margin: 1px;
    padding: 1px;
    background: transparent;
    }

    Si alguna vez os pasa ya sabeis.
    :gracias:


  16. Edu dice:

    Siento que el codigo no salga :oops: lo intentare de nuevo

    Asi en la parte del codigo donde insertaba las imagenes las etiquetas “” y “” las encerré entre “…..
    Al mismo tiempo, para que funcionara creé tambien en style.css la regla anterior


  17. sisifodichoso dice:

    Hola Edu, ante todo gracias por tu contribución :-)
    Por lo que comentas habría alguna incompatibilidad de los estilos de etiquetags con los que tienes definidos para las imágenes en tu sitio web.
    La solución que tu aportas está bien siempre que te funcione ;-) pero me da en la nariz que si haces que los separadores sean botones y por casualidad haces click en un separador en vez de en un botón, se podría generar un error de javascript (esto se puede monitorizar en la consola de error de firefox)
    ¿Has probado a dejarlos como imágenes, es decir como estaba, y darles estilo?
    Los botones son la clase .ed_sep_button. En la hoja de estilos del paquete hay una errata y pone .ed_sep_botton :oops: Intentaré corregirlo en breve …

    ¿Las etiquetas ‘y’… son esas de seguir leyendo y cosas así … ? :hmm:

    En cualquier caso, ya te digo, muchas gracias porque esto pone en la pista, buena, para solucionar futuros problemas
    :gracias: :-)


  18. pascual dice:

    Buenos dias :clap:

    Queria comentaros un problemilla que me surje cuando introduzco dos etiquetags en la misma pagina en diferentes textareas, por ejemplo: tengo un textarea para una descripcion y otro textarea para una historia etc… El problema en si es que en el primer textarea no me introduce bien las etiquetas de modificacion, o que hace es no introducirme nada y me mete una etiqueta de apertura en el segundo textarea( tienen diferentes ids y los scripts hacen referencia cada cual a su textarea) y en el segundo no da ningun problema…

    Por favor os agradeceria que me dijerais cual es el problema, muchas gracias por adelantado y muy buen trabajo :yupi: :gracias:


  19. sisi dice:

    Hola Pascual,
    ante todo gracias por tu comentario.
    Efectivamente etiquetags 1.1 está concebido para usarlo en una textarea. Si usas dos etiquetags, uno para cada textarea, se hace un lío (porque presupone que hay una y busca una textarea llamada “canvas”) y no sabe donde insertar las etiquetas… Existe no obstante una versión “familiar” que llamamos “multitextarea”, y que aún no está publicada, que consigue con un sólo etiquetags insertar etiquetas en cualquier número de textareas de una página … lo tengo que mirar porque no sé ni donde lo tengo, así que no puedo asegurarte nada de momento pero si tengo alguna novedad lo publicaré en este blog … :gracias: de nuevo y un saludo :-)


  20. flaco dice:

    estoy utilizando etiquetatgs en un cms propio y me pasa una cosa rara. tengo 2 paginas .php una para ingresar una nota y otra para editarla
    la de ingresar la nota va bien pero la de editarla me aparece bien la barra de los iconos pero no coloca las etiquetas para darle formato y me dice que etiquetatags es “nulo” que hay un error? como puedo solucionarlo?


  21. sisi dice:

    Hola flaco,

    suponemos que cada página tiene un textarea donde insertar las etiquetas y no hay múltiples textareas en una misma página. Si esto es así, dínoslo y si no, sigue leyendo a ver si damos con ello.

    ten en cuenta que cada página donde utilices etiquetags debe incluir el siguiente código o similar:

    <script type="text/javascript">edToolbar();</script>
    <textarea id="canvas" rows="20" cols="80"></textarea>
    <script type="text/javascript">var edCanvas = document.getElementById('canvas');</script>

    si no le decimos bien a etiquetags cuál es el id del textarea donde insertamos las etiquetas, el navegador da un error “myField is null”.
    Esto ocurre, por ejemplo, con el siguiente código:
    <script type="text/javascript">edToolbar();</script>
    <textarea id="canvas01" rows="20" cols="80"></textarea>
    <script type="text/javascript">var edCanvas = document.getElementById('canvas');</script>

    mira a ver esto, si no te sirve, igual tienes que darnos alguna pista más.

    Muchas gracias por utilizar etiquetags

    saludos